about summary refs log tree commit homepage
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2013-06-21 03:34:39 +0000
committerEric Wong <normalperson@yhbt.net>2013-06-25 22:07:51 +0000
commitcb6851fc69a3fb3d47e4e3a350787deef1bfafa6 (patch)
treef391a86a50553f45aa3fdf183b3e29b4b904c1bd /configure.ac
parentc1ced9e91ddc647a40f343d20d43cf13fe88eeba (diff)
downloadcmogstored-cb6851fc69a3fb3d47e4e3a350787deef1bfafa6.tar.gz
For difficult-to-trigger errors, fault injection is necessary for
testing our error handling.  I have confirmed this test fails with
"avoid leaks on epoll/kqueue resources exhaustion" reverted.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5cfdc9b..7194216 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,9 @@ dnl gnulib *at functions aren't thread-safe, ask for the real thing
 AC_CHECK_FUNCS([openat renameat mkdirat fstatat unlinkat])
 
 AC_CHECK_FUNCS([epoll_wait epoll_pwait ppoll])
+AC_CHECK_FUNCS([epoll_ctl], [HAVE_EPOLL=1], [HAVE_EPOLL=0])
+AC_SUBST(HAVE_EPOLL)
+AM_CONDITIONAL(HAVE_EPOLL, test "x$HAVE_EPOLL" = "x1")
 
 dnl libkqueue should work in the future
 AC_CHECK_FUNCS([kqueue])
@@ -65,6 +68,7 @@ esac
 ])
 
 CM_SYSTEMTAP
+CM_LD_WRAP
 
 AC_CONFIG_FILES([Makefile lib/Makefile])
 AC_OUTPUT