about summary refs log tree commit homepage
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2013-06-21 03:34:36 +0000
committerEric Wong <normalperson@yhbt.net>2013-06-25 22:07:42 +0000
commite12e70b6bd242cb3fea74d1df8b7b44e0a9f7f26 (patch)
tree49f915d77028ae98852243efed2ab3c7c8323660 /configure.ac
parenta18a08a0e9a7c472656afc86cbbbfcefda5e456d (diff)
downloadcmogstored-e12e70b6bd242cb3fea74d1df8b7b44e0a9f7f26.tar.gz
While pthread_yield is non-standard, it is relatively common and
preferable for systems where pthreads are _not_ 1:1 mapped to kernel
threads.  This also provides a stronger yield to weaken the priority
of the calling thread wherever we previously used sched_yield.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8a9e6d1..5cfdc9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,9 @@ AC_CHECK_FUNCS([sendfile])
 AC_CHECK_FUNCS([open_memstream])
 AC_CHECK_FUNCS([posix_fadvise])
 
+dnl non-standard, but common
+AC_CHECK_FUNCS([pthread_yield])
+
 dnl gnulib doesn't actually define SOCK_NONBLOCK/SOCK_CLOEXEC, and
 dnl even if it did, emulation wouldn't be thread-safe
 AC_CHECK_FUNCS([accept4])