about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 494bfa8..ad19560 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -169,6 +169,12 @@ test_epoll_wrap_SOURCES = $(cmogstored_SOURCES) test/epoll-wrap.c
 test_epoll_wrap_LDFLAGS = $(cmogstored_LDFLAGS) $(AM_LDFLAGS) \
                           -Wl,--wrap=epoll_ctl -Wl,--wrap=epoll_create
 endif # HAVE_EPOLL
+
+check_PROGRAMS += test/pwrite-wrap
+test_pwrite_wrap_SOURCES = $(cmogstored_SOURCES) test/pwrite-wrap.c
+test_pwrite_wrap_LDFLAGS = $(cmogstored_LDFLAGS) $(AM_LDFLAGS) \
+                          -Wl,--wrap=pwrite
+
 endif # HAVE_LD_WRAP
 
 HELP2MAN = help2man