about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3ce8cf0..157242f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -87,6 +87,7 @@ mog_src += sig.c
 mog_src += svc.c
 mog_src += svc_dev.c
 mog_src += thrpool.c
+mog_src += trace.h
 mog_src += trywrite.c
 mog_src += util.h
 mog_src += upgrade.c
@@ -113,7 +114,7 @@ chunk_parser.c: chunk_parser.rl http_common.rl
 
 BUILT_SOURCES = $(top_srcdir)/.version
 bin_PROGRAMS = cmogstored
-cmogstored_SOURCES = $(mog_src) $(RL_CGEN) cmogstored.c
+cmogstored_SOURCES = $(mog_src) $(RL_CGEN) cmogstored.c probes.d
 
 RUBY = ruby
 PERL = perl
@@ -217,3 +218,14 @@ $(top_srcdir)/.version:
         echo $(VERSION) > $@-t && mv $@-t $@
 dist-hook:
         echo $(VERSION) > $(distdir)/.tarball-version
+
+if ENABLE_SYSTEMTAP
+BUILT_SOURCES += probes.h
+probes.h: probes.d
+        $(DTRACE) -C -h -s $< -o $@
+
+probes.o: probes.d
+        $(DTRACE) -C -G -s $< -o $@
+
+LDADD += probes.o
+endif