about summary refs log tree commit homepage
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1911f4d..f9b3e7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,6 +55,10 @@ dnl gnulib doesn't actually define SOCK_NONBLOCK/SOCK_CLOEXEC, and
 dnl even if it did, emulation wouldn't be thread-safe
 AC_CHECK_FUNCS([accept4])
 
+dnl needed for glibc malloc tuning
+AC_CHECK_HEADERS([malloc.h])
+AC_CHECK_FUNCS([mallopt])
+
 AC_SUBST(NOSTD_CFLAGS)
 
 # This works for all platforms we care about: