Rainbows! Rack HTTP server user/dev discussion
 help / Atom feed
* Rainbows gemspec lists Unicorn with a broad dependency
@ 2014-01-16 19:13 Damian Janowski
       [not found] ` <CABAijKEeAyxPS8F4hRXN+veKVwcCaZRkm90PjNijMwbfZASEFA-JsoAwUIsXosN+BqQ9rBEUg@public.gmane.org>
  0 siblings, 1 reply; 4+ messages in thread
From: Damian Janowski @ 2014-01-16 19:13 UTC (permalink / raw)
  To: Rainbows! list

Eric,

Rainbows lists the Unicorn dependency passing an array [1]. I saw that
this is used in the RubyGems documentation, but apparently it's
broken–probably on RubyGems' side.

I did a fresh install of Rainbows 4.3.1 and it installed Unicorn
4.8.0. This combo makes Rainbows not boot due to an exception (someone
trying to call TrueClass#dup).

Maybe the ability to combine both optimistic and strict version
requirements is not worth it?

Thanks.
D.

[1] http://bogomips.org/rainbows.git/tree/rainbows.gemspec#n32
_______________________________________________
Rainbows! mailing list - rainbows-talk-GrnCvJ7WPxnNLxjTenLetw@public.gmane.org
http://rubyforge.org/mailman/listinfo/rainbows-talk
Do not quote signatures (like this one) or top post when replying


^ permalink raw reply	[flat|threaded] 4+ messages in thread

* Re: Rainbows gemspec lists Unicorn with a broad dependency
       [not found] ` <CABAijKEeAyxPS8F4hRXN+veKVwcCaZRkm90PjNijMwbfZASEFA-JsoAwUIsXosN+BqQ9rBEUg@public.gmane.org>
@ 2014-01-16 19:46   ` Eric Wong
       [not found]     ` <20140116194634.GA13492-yBiyF41qdooeIZ0/mPfg9Q@public.gmane.org>
  0 siblings, 1 reply; 4+ messages in thread
From: Eric Wong @ 2014-01-16 19:46 UTC (permalink / raw)
  To: Rainbows! list; +Cc: Damian Janowski

Damian Janowski <jano@dimaion.com> wrote:
> Eric,
> 
> Rainbows lists the Unicorn dependency passing an array [1]. I saw that
> this is used in the RubyGems documentation, but apparently it's
> broken–probably on RubyGems' side.
> 
> I did a fresh install of Rainbows 4.3.1 and it installed Unicorn
> 4.8.0. This combo makes Rainbows not boot due to an exception (someone
> trying to call TrueClass#dup).

Can you show us a backtrace and any parts of your config which
may be relevant?  I can't seem to reproduce it with either
rainbows 4.3.1 nor 4.5.0.

Nothing in unicorn 4.8 should've broken Rainbows! compatibility.

> Maybe the ability to combine both optimistic and strict version
> requirements is not worth it?
> 
> Thanks.
> D.
> 
> [1] http://bogomips.org/rainbows.git/tree/rainbows.gemspec#n32
_______________________________________________
Rainbows! mailing list - rainbows-talk@rubyforge.org
http://rubyforge.org/mailman/listinfo/rainbows-talk
Do not quote signatures (like this one) or top post when replying

^ permalink raw reply	[flat|threaded] 4+ messages in thread

* Re: Rainbows gemspec lists Unicorn with a broad dependency
       [not found]     ` <20140116194634.GA13492-yBiyF41qdooeIZ0/mPfg9Q@public.gmane.org>
@ 2014-01-16 20:00       ` Eric Wong
       [not found]         ` <20140116200053.GA17620-yBiyF41qdooeIZ0/mPfg9Q@public.gmane.org>
  0 siblings, 1 reply; 4+ messages in thread
From: Eric Wong @ 2014-01-16 20:00 UTC (permalink / raw)
  To: Rainbows! list; +Cc: Damian Janowski

Eric Wong <normalperson-rMlxZR9MS24@public.gmane.org> wrote:
> Nothing in unicorn 4.8 should've broken Rainbows! compatibility.

Actually, sorry, things did break with the signalling changes.
Sorry about that, I completely overlooked that :x
_______________________________________________
Rainbows! mailing list - rainbows-talk-GrnCvJ7WPxnNLxjTenLetw@public.gmane.org
http://rubyforge.org/mailman/listinfo/rainbows-talk
Do not quote signatures (like this one) or top post when replying


^ permalink raw reply	[flat|threaded] 4+ messages in thread

* Re: Rainbows gemspec lists Unicorn with a broad dependency
       [not found]         ` <20140116200053.GA17620-yBiyF41qdooeIZ0/mPfg9Q@public.gmane.org>
@ 2014-01-16 21:02           ` Damian Janowski
  0 siblings, 0 replies; 4+ messages in thread
From: Damian Janowski @ 2014-01-16 21:02 UTC (permalink / raw)
  To: Eric Wong; +Cc: Rainbows! list

On Thu, Jan 16, 2014 at 5:00 PM, Eric Wong <normalperson-rMlxZR9MS24@public.gmane.org> wrote:
> Eric Wong <normalperson-rMlxZR9MS24@public.gmane.org> wrote:
>> Nothing in unicorn 4.8 should've broken Rainbows! compatibility.
>
> Actually, sorry, things did break with the signalling changes.
> Sorry about that, I completely overlooked that :x

No problem, thank you for your beautiful software :)

Let me know if you need anything from me.
_______________________________________________
Rainbows! mailing list - rainbows-talk-GrnCvJ7WPxnNLxjTenLetw@public.gmane.org
http://rubyforge.org/mailman/listinfo/rainbows-talk
Do not quote signatures (like this one) or top post when replying


^ permalink raw reply	[flat|threaded] 4+ messages in thread

end of thread, back to index

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-01-16 19:13 Rainbows gemspec lists Unicorn with a broad dependency Damian Janowski
     [not found] ` <CABAijKEeAyxPS8F4hRXN+veKVwcCaZRkm90PjNijMwbfZASEFA-JsoAwUIsXosN+BqQ9rBEUg@public.gmane.org>
2014-01-16 19:46   ` Eric Wong
     [not found]     ` <20140116194634.GA13492-yBiyF41qdooeIZ0/mPfg9Q@public.gmane.org>
2014-01-16 20:00       ` Eric Wong
     [not found]         ` <20140116200053.GA17620-yBiyF41qdooeIZ0/mPfg9Q@public.gmane.org>
2014-01-16 21:02           ` Damian Janowski

Rainbows! Rack HTTP server user/dev discussion

Archives are clonable:
	git clone --mirror http://bogomips.org/rainbows-public
	git clone --mirror http://ou63pmih66umazou.onion/rainbows-public

Newsgroups are available over NNTP:
	nntp://news.public-inbox.org/inbox.comp.lang.ruby.rainbows
	nntp://ou63pmih66umazou.onion/inbox.comp.lang.ruby.rainbows

 note: .onion URLs require Tor: https://www.torproject.org/
       or Tor2web: https://www.tor2web.org/

AGPL code for this site: git clone https://public-inbox.org/ public-inbox