about summary refs log tree commit homepage
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b63ab40..ca202da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,7 +34,8 @@ AC_C_FLEXIBLE_ARRAY_MEMBER
 dnl gnulib *at functions aren't thread-safe, ask for the real thing
 AC_CHECK_FUNCS([openat renameat mkdirat fstatat unlinkat])
 
-AC_CHECK_FUNCS([epoll_wait])
+AC_CHECK_HEADERS_ONCE([sys/eventfd.h])
+AC_CHECK_FUNCS([epoll_wait eventfd])
 
 dnl libkqueue should work in the future
 AC_CHECK_FUNCS([kqueue])