about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2013-01-26 00:19:59 +0000
committerEric Wong <normalperson@yhbt.net>2013-01-31 02:10:44 +0000
commit2b252bb6b4704be01d629194aff588b24d579cdd (patch)
treef7c16ff729f20a1befc7e0fde4f50f1b71856637 /Makefile.am
parente292e0e874a064fcd39f76565f38935449b7f7c8 (diff)
downloadcmogstored-2b252bb6b4704be01d629194aff588b24d579cdd.tar.gz
To support transparent upgrades, we need to be able to reap
child processes regardless of what the child process was.  So we
must do away with the iostat/worker-specifc waitpid() calls and
use waitpid(-1) to cast a wide net to reap anything and
everything.

When we support transparent upgrades, the fork+exec-ed child
process may die, so the main process (master if
--worker-processes are used) needs to be capable of reaping
that new process.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 210eaab..39011aa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,6 +69,7 @@ mog_src += nostd/setproctitle.h
 mog_src += notify.c
 mog_src += notify.h
 mog_src += pidfile.c
+mog_src += process.c
 mog_src += queue_common.c
 mog_src += queue_epoll.c
 mog_src += queue_epoll.h