about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2012-05-02 09:25:42 +0000
committerEric Wong <normalperson@yhbt.net>2012-05-02 09:25:42 +0000
commit48e0cdb616ba09757c30f02d900657f381eaae46 (patch)
treef6accc18acd87cbd8c8c738f70ddef212fc6ac6b /Makefile.am
parente0857dffa251e0976bc658346ec73cc02e4dc435 (diff)
downloadcmogstored-48e0cdb616ba09757c30f02d900657f381eaae46.tar.gz
We can only rebuild the manpage if cmogstored is present.  When
building in subdirectories, our manpage-hack.mk snippet won't
work.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index bbc0cd8..b235880 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -151,8 +151,9 @@ dist_man_MANS = cmogstored.1
 
 cmogstored.1: cmogstored.x $(cmogstored_SOURCES)
 .x.1:
-        $(AM_V_GEN)$(HELP2MAN) -i $< -N $(top_builddir)/cmogstored \
-          > $@.$$$$ && mv $@.$$$$ $@
+        $(AM_V_GEN)if test -f $(top_builddir)/cmogstored; then \
+        $(HELP2MAN) -i $< -N $(top_builddir)/cmogstored > $@.$$$$ && \
+        mv $@.$$$$ $@; fi
 
 extra_doc = HACKING NEWS ChangeLog TODO
 RAKE = rake