about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2013-02-15 02:40:50 +0000
committerEric Wong <normalperson@yhbt.net>2013-02-15 02:40:50 +0000
commit5629899a12649b9b21f41efc29b92adbd82afe6c (patch)
tree8f97f684d65356623af0610e5587bebaa9af6129 /Makefile.am
parent44f4f76d06899b1a0e4719671a4fde3c0851764a (diff)
downloadcmogstored-5629899a12649b9b21f41efc29b92adbd82afe6c.tar.gz
This will inform the user of why cmogstored may be slow
to start, since we need the mountlist to be populated at
startup.

We also throw a pthread_cancel() in there to load libgcc_s under
glibc, so we can avoid loading libgcc_s once we're under FD pressure.
This makes test/http_idle_expire.rb more reliable.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e2b598..6fa520c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
 ACLOCAL_AMFLAGS = -I m4
 AM_CPPFLAGS = -I$(top_builddir)/lib -I$(top_srcdir)/lib
 AM_CFLAGS = $(WARN_CFLAGS) $(PTHREAD_CFLAGS)
-AM_LDFLAGS = $(LIBGNU_LIBDEPS)
+AM_LDFLAGS = $(LIBGNU_LIBDEPS) $(LIB_CLOCK_GETTIME)
 SUBDIRS = lib
 
 # slow.mk is auto-generated by the maintainer (see GNUmakefile)