about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2012-12-04 12:08:17 +0000
committerEric Wong <normalperson@yhbt.net>2012-12-04 12:08:17 +0000
commit712f330713a20b554d01a769819548d9dc675980 (patch)
treea69ab8e032248771f3e336aefae6ba0f8babe5b9 /Makefile.am
parenteeb22d5e0fbbdbb51a7e1e77916ec0d27e944ac7 (diff)
downloadcmogstored-712f330713a20b554d01a769819548d9dc675980.tar.gz
Since we rely on gnulib-modified stdio.h/string.h headers,
we'll need the generated config.h to make sense of them.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ffa8463..3d32fe6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -82,6 +82,7 @@ mog_src += warn.c
 
 LDADD = $(LIBINTL) $(top_builddir)/lib/libgnu.a libnostd.a
 noinst_LIBRARIES = libnostd.a
+NOSTD_CFLAGS = -include $(top_builddir)/$(CONFIG_HEADER)
 libnostd_a_SOURCES = nostd/setproctitle.c nostd/setproctitle_noop.c
 libnostd_a_CFLAGS = $(AM_CFLAGS) $(NOSTD_CFLAGS)