about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2013-04-14 00:50:09 +0000
committerEric Wong <normalperson@yhbt.net>2013-04-17 03:35:14 +0000
commit7b097d6129a7971197430d817682163adb8e2e8a (patch)
treeb2bd80fc3663be72c22732938190607ce090c481 /Makefile.am
parent449b85daa42cae1b9542a26e6dd52a1db38cce93 (diff)
downloadcmogstored-7b097d6129a7971197430d817682163adb8e2e8a.tar.gz
getpeername() does not work on unconnected sockets.  For error-handling,
unconnected sockets is a fairly common occurrence, so we want to get
the address early on when we know the address is still valid.

For IPv4 addresses, this does not increase memory overhead at all.  IPv6
addresses[1] does require an additional heap allocation, but it does not
need to be aligned since it is infrequently accessed.  If IPv6 becomes
common, we may need to expand our per-client storage to 192 bytes (from
128) on 64-bit (or see if we may pack data more carefully).

[1] IPv6 addresses are rare with MogileFS, as MogileFS does not
    currently support them.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index dc556c5..3ce8cf0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,6 +70,8 @@ mog_src += nameinfo.c
 mog_src += nostd/setproctitle.h
 mog_src += notify.c
 mog_src += notify.h
+mog_src += packaddr.c
+mog_src += packaddr.h
 mog_src += pidfile.c
 mog_src += process.c
 mog_src += queue_common.c