about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2013-06-21 03:34:14 +0000
committerEric Wong <normalperson@yhbt.net>2013-06-25 21:25:28 +0000
commit89f0cf089b9e68730948ce652b42efaf26b98fd2 (patch)
tree674f2c0172f3612bf4e52422418ce6a3722dec6b /Makefile.am
parent2376ed3c3da3bd2c9e8326e7dd75be2188fffc35 (diff)
downloadcmogstored-89f0cf089b9e68730948ce652b42efaf26b98fd2.tar.gz
This will allow us to do lookups for IO queues/semaphores before
we attempt to fstatat/stat a path.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 499def1..e57d2cf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,11 +103,12 @@ RAGEL = ragel
 RL_MAIN = cfg_parser.rl iostat_parser.rl listen_parser.rl mgmt_parser.rl \
           valid_path.rl http_parser.rl chunk_parser.rl valid_put_path.rl
 RL_CGEN = $(RL_MAIN:.rl=.c)
-RL_ALL = listen_parser_common.rl http_common.rl $(RL_MAIN)
+RL_ALL = listen_parser_common.rl http_common.rl path_parser.rl $(RL_MAIN)
 
 cfg_parser.c: cfg_parser.rl listen_parser_common.rl
 listen_parser.c: listen_parser.rl listen_parser_common.rl
-http_parser.c: http_parser.rl http_common.rl
+http_parser.c: http_parser.rl http_common.rl path_parser.rl
+mgmt_parser.c: path_parser.rl
 chunk_parser.c: chunk_parser.rl http_common.rl
 .rl.c:
         $(AM_V_GEN)$(RAGEL) $< -C $(RLFLAGS) -o $@