about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2013-06-21 11:17:47 +0000
committerEric Wong <normalperson@yhbt.net>2013-06-25 19:53:09 +0000
commit97ed7a71d216eb4c6cbd1c40f2759e8d8957864a (patch)
tree8a1bd20ab30ee0ee58a05b61d54a36f34dc39273 /Makefile.am
parent0ad0f16bce2769a599eb718261e0283e79c57639 (diff)
downloadcmogstored-97ed7a71d216eb4c6cbd1c40f2759e8d8957864a.tar.gz
This is useful for:
a) repeatibly generating the same tarball off git
b) diagnosing and tracking down (rare) gnulib bugs
c) 3rd parties verifying we do not put malicious code into our tarballs
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 157242f..499def1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -112,7 +112,7 @@ chunk_parser.c: chunk_parser.rl http_common.rl
 .rl.c:
         $(AM_V_GEN)$(RAGEL) $< -C $(RLFLAGS) -o $@
 
-BUILT_SOURCES = $(top_srcdir)/.version
+BUILT_SOURCES = $(top_srcdir)/.version $(top_srcdir)/.gnulib-version
 bin_PROGRAMS = cmogstored
 cmogstored_SOURCES = $(mog_src) $(RL_CGEN) cmogstored.c probes.d
 
@@ -195,7 +195,7 @@ EXTRA_DIST = $(RB_TESTS) $(RL_CGEN) $(RL_ALL) $(PERL_TESTS) $(extra_doc) \
   cmogstored.x .ctags $(SLOW_RB_FILES) \
   build-aux/.gitignore build-aux/snippet/.gitignore \
   tests/.gitignore \
-  $(top_srcdir)/.version \
+  $(top_srcdir)/.version $(top_srcdir)/.gnulib-version \
   test/valgrind.supp nostd/README
 
 TESTS_ENVIRONMENT = PATH=$(top_builddir):$$PATH TMPDIR=$(test_tmpdir)
@@ -216,6 +216,8 @@ include $(top_srcdir)/build-aux/pgo.mk
 
 $(top_srcdir)/.version:
         echo $(VERSION) > $@-t && mv $@-t $@
+$(top_srcdir)/.gnulib-version:
+        cd $(top_srcdir) && ./autogen.sh
 dist-hook:
         echo $(VERSION) > $(distdir)/.tarball-version