about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2013-01-30 11:59:58 +0000
committerEric Wong <normalperson@yhbt.net>2013-01-31 02:09:14 +0000
commita960a351b2248a196c91cdbf6256f98e1bc2ef37 (patch)
tree91d3c4898affb339f9642c1f68911f5253681358 /Makefile.am
parent2e1958b26b926c42f213ba47b71ec735d81448e7 (diff)
downloadcmogstored-a960a351b2248a196c91cdbf6256f98e1bc2ef37.tar.gz
This prevents us from losing iostat utilization each time the
mount list is rescanned.

Additionally, this allows us to read iostat utilization (and
write to sidechannel clients) concurrently while the mount list
is being refreshed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bc94a1b..6215b95 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -51,6 +51,7 @@ mog_src += ioprio_linux.h
 mog_src += iostat.c
 mog_src += iostat.h
 mog_src += iostat_process.c
+mog_src += ioutil.c
 mog_src += iov_str.h
 mog_src += listen_parser.h
 mog_src += listen_parser_internal.c
@@ -120,7 +121,8 @@ include $(top_srcdir)/test/ruby.mk
 check_PROGRAMS = test/valid-path-1 test/trywrite-1 \
   test/cfg-parser-1 test/fdmap-1 test/thrpool-1 \
   test/queue-idle-1 \
-  test/http-parser-1 test/chunk-parser-1
+  test/http-parser-1 test/chunk-parser-1 \
+  test/ioutil-1
 
 TESTS = $(SLOW_RB_FILES) $(RB_TESTS_FAST) $(check_PROGRAMS) $(PERL_TESTS)
 
@@ -143,6 +145,7 @@ test_thrpool_1_SOURCES = test/thrpool-1.c $(test_COMMON)
 test_queue_idle_1_SOURCES = test/queue-idle-1.c $(test_COMMON)
 test_http_parser_1_SOURCES = test/http-parser-1.c $(test_COMMON)
 test_chunk_parser_1_SOURCES = test/chunk-parser-1.c $(test_COMMON)
+test_ioutil_1_SOURCES = test/ioutil-1.c $(test_COMMON)
 
 HELP2MAN = help2man
 dist_man_MANS = cmogstored.1