about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2012-07-11 22:08:08 +0000
committerEric Wong <normalperson@yhbt.net>2012-07-12 01:05:09 +0000
commitb19f9e707ab1ebea748ccc9dcf2d8d6cadf4e616 (patch)
treed89812f2fe154655a959b031a0d2dac25b24d565 /Makefile.am
parent49df2ac41136e8ab9b0fe01fbb46c0aefb924eb1 (diff)
downloadcmogstored-b19f9e707ab1ebea748ccc9dcf2d8d6cadf4e616.tar.gz
Epoll/kqueue descriptors are safely usable for this task given
the the ability to use one-shot notifications (which is
independent of level-triggering, even).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 510ab18..532ee45 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,7 +10,6 @@ include $(top_srcdir)/test/slow.mk
 mog_src =
 mog_src += accept.c
 mog_src += accept_loop.c
-mog_src += activeq.c
 mog_src += activeq.h
 mog_src += addrinfo.c
 mog_src += alloc.c
@@ -119,7 +118,7 @@ SLOWRB_LOG_COMPILER = RUBY="$(RUBY)"
 AM_SLOWRB_LOG_FLAGS = top_srcdir="$(top_srcdir)"
 include $(top_srcdir)/test/ruby.mk
 check_PROGRAMS = test/valid-path-1 test/trywrite-1 \
-  test/cfg-parser-1 test/fdmap-1 test/thrpool-1 test/queue-1 \
+  test/cfg-parser-1 test/fdmap-1 test/thrpool-1 \
   test/queue-idle-1 \
   test/http-parser-1 test/chunk-parser-1
 
@@ -141,7 +140,6 @@ test_trywrite_1_SOURCES = test/trywrite-1.c $(test_COMMON)
 test_cfg_parser_1_SOURCES = test/cfg-parser-1.c $(test_COMMON)
 test_fdmap_1_SOURCES = test/fdmap-1.c $(test_COMMON)
 test_thrpool_1_SOURCES = test/thrpool-1.c $(test_COMMON)
-test_queue_1_SOURCES = test/queue-1.c $(test_COMMON)
 test_queue_idle_1_SOURCES = test/queue-idle-1.c $(test_COMMON)
 test_http_parser_1_SOURCES = test/http-parser-1.c $(test_COMMON)
 test_chunk_parser_1_SOURCES = test/chunk-parser-1.c $(test_COMMON)