about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2012-07-09 21:18:33 +0000
committerEric Wong <normalperson@yhbt.net>2012-07-09 22:31:42 +0000
commitbdb327b11137d8b184ff0322eb90ce6e837db53d (patch)
treec99028a1b67d2af1366ab83e8d7eaa04d78b26bb /Makefile.am
parent663cb7902ac252705df6fc0191fbf6f57d4cbb98 (diff)
downloadcmogstored-bdb327b11137d8b184ff0322eb90ce6e837db53d.tar.gz
gnulib now includes tests by default in the "tests/" directory.
We'll also avoid importing certain modules that our platforms
will never need to save some space in the tarball.

Based on gnulib commit 48fe477c9008efadab8cf8c0c3240d824c12a8b9
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b235880..510ab18 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@ ACLOCAL_AMFLAGS = -I m4
 AM_CPPFLAGS = -I$(top_builddir)/lib -I$(top_srcdir)/lib
 AM_CFLAGS = $(WARN_CFLAGS) $(PTHREAD_CFLAGS)
 AM_LDFLAGS = $(LIBGNU_LIBDEPS)
-SUBDIRS = lib
+SUBDIRS = lib tests
 
 # slow.mk is auto-generated by the maintainer (see GNUmakefile)
 include $(top_srcdir)/test/slow.mk
@@ -182,6 +182,7 @@ EXTRA_DIST = $(RB_TESTS) $(RL_CGEN) $(RL_ALL) $(PERL_TESTS) $(extra_doc) \
   test/.gitignore test/gen-slow.sh test/slow.mk \
   cmogstored.x .ctags $(SLOW_RB_FILES) \
   build-aux/.gitignore build-aux/snippet/.gitignore \
+  tests/.gitignore \
   $(top_srcdir)/.version \
   test/valgrind.supp nostd/README