about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2013-06-21 03:34:36 +0000
committerEric Wong <normalperson@yhbt.net>2013-06-25 22:07:42 +0000
commite12e70b6bd242cb3fea74d1df8b7b44e0a9f7f26 (patch)
tree49f915d77028ae98852243efed2ab3c7c8323660 /Makefile.am
parenta18a08a0e9a7c472656afc86cbbbfcefda5e456d (diff)
downloadcmogstored-e12e70b6bd242cb3fea74d1df8b7b44e0a9f7f26.tar.gz
While pthread_yield is non-standard, it is relatively common and
preferable for systems where pthreads are _not_ 1:1 mapped to kernel
threads.  This also provides a stronger yield to weaken the priority
of the calling thread wherever we previously used sched_yield.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 918200c..dd1e9e3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -92,6 +92,7 @@ mog_src += trace.h
 mog_src += trywrite.c
 mog_src += util.h
 mog_src += upgrade.c
+mog_src += yield.c
 
 LDADD = $(LIBINTL) $(top_builddir)/lib/libgnu.a libnostd.a
 noinst_LIBRARIES = libnostd.a