about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2013-05-06 22:20:05 +0000
committerEric Wong <normalperson@yhbt.net>2013-05-06 22:20:21 +0000
commitf80c52cfe4e08fba39995830a3fcf5835d0bb846 (patch)
tree4ed83563f04c68492f79c3f7b9e1089356db01f7 /Makefile.am
parentb60e0eebc4e108f63372f9a0ffe318589599728f (diff)
downloadcmogstored-f80c52cfe4e08fba39995830a3fcf5835d0bb846.tar.gz
We will key most client events by pid() and file descriptors,
as this is least ambiguous.  There are some minor refactorings
to pass "struct mog_fd *" around as much as possible instead of
"struct mog_http *".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3ce8cf0..157242f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -87,6 +87,7 @@ mog_src += sig.c
 mog_src += svc.c
 mog_src += svc_dev.c
 mog_src += thrpool.c
+mog_src += trace.h
 mog_src += trywrite.c
 mog_src += util.h
 mog_src += upgrade.c
@@ -113,7 +114,7 @@ chunk_parser.c: chunk_parser.rl http_common.rl
 
 BUILT_SOURCES = $(top_srcdir)/.version
 bin_PROGRAMS = cmogstored
-cmogstored_SOURCES = $(mog_src) $(RL_CGEN) cmogstored.c
+cmogstored_SOURCES = $(mog_src) $(RL_CGEN) cmogstored.c probes.d
 
 RUBY = ruby
 PERL = perl
@@ -217,3 +218,14 @@ $(top_srcdir)/.version:
         echo $(VERSION) > $@-t && mv $@-t $@
 dist-hook:
         echo $(VERSION) > $(distdir)/.tarball-version
+
+if ENABLE_SYSTEMTAP
+BUILT_SOURCES += probes.h
+probes.h: probes.d
+        $(DTRACE) -C -h -s $< -o $@
+
+probes.o: probes.d
+        $(DTRACE) -C -G -s $< -o $@
+
+LDADD += probes.o
+endif