about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2013-02-14 05:21:27 +0000
committerEric Wong <normalperson@yhbt.net>2013-02-14 10:19:40 +0000
commitf8b30b2846c25461940c99d8fd4432ec49920098 (patch)
tree73d43173e81dbbe3a6dca8ed0cc47e381a17a81e /Makefile.am
parent4ccf06a600ce31c6dbd61d9c44b491233758c18b (diff)
downloadcmogstored-f8b30b2846c25461940c99d8fd4432ec49920098.tar.gz
This saves us a file descriptor in Linux, which provides
epoll_pwait in 2.6.19+ (and ppoll for 2.6.18, the oldest
kernel we support).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8ec860c..1e2b598 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,6 +25,7 @@ mog_src += cloexec_from.c
 mog_src += close.c
 mog_src += cmogstored.h
 mog_src += compat_accept.h
+mog_src += compat_epoll_pwait.h
 mog_src += compat_memstream.h
 mog_src += compat_sendfile.h
 mog_src += defaults.h
@@ -77,8 +78,7 @@ mog_src += queue_kqueue.c
 mog_src += queue_kqueue.h
 mog_src += queue_loop.c
 mog_src += queue_step.c
-mog_src += selfwake_eventfd.h
-mog_src += selfwake_pipe.h
+mog_src += selfwake.h
 mog_src += selfwake.c
 mog_src += sig.c
 mog_src += svc.c