about summary refs log tree commit homepage
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2012-02-09 20:31:42 +0000
committerEric Wong <normalperson@yhbt.net>2012-02-09 20:42:36 +0000
commit495e5aab0d856b0845a1475b7eac78468b45d99a (patch)
tree8daa8a013fcbbb3c951e1651dd130eefabfab872 /configure.ac
parent0f760d373792072e8ecda0c0395616598004a34a (diff)
downloadcmogstored-495e5aab0d856b0845a1475b7eac78468b45d99a.tar.gz
We want as much debugging information as possible, and -ggdb3
should give us even macro expansion.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ef373fe..3c0692f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,7 +26,7 @@ gl_WARN_ADD([-Werror=char-subscripts])
 gl_WARN_ADD([-Werror=pointer-arith])
 gl_WARN_ADD([-Werror-implicit-function-declaration])
 gl_WARN_ADD([-Werror=declaration-after-statement]) dnl I hate C99 for this :P
-
+gl_WARN_ADD([-ggdb3],[CFLAGS])
 AX_PTHREAD(true)
 AC_SYS_LARGEFILE
 AC_C_FLEXIBLE_ARRAY_MEMBER