about summary refs log tree commit homepage
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2013-02-14 05:21:27 +0000
committerEric Wong <normalperson@yhbt.net>2013-02-14 10:19:40 +0000
commitf8b30b2846c25461940c99d8fd4432ec49920098 (patch)
tree73d43173e81dbbe3a6dca8ed0cc47e381a17a81e /configure.ac
parent4ccf06a600ce31c6dbd61d9c44b491233758c18b (diff)
downloadcmogstored-f8b30b2846c25461940c99d8fd4432ec49920098.tar.gz
This saves us a file descriptor in Linux, which provides
epoll_pwait in 2.6.19+ (and ppoll for 2.6.18, the oldest
kernel we support).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ca202da..08cab08 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,8 +34,7 @@ AC_C_FLEXIBLE_ARRAY_MEMBER
 dnl gnulib *at functions aren't thread-safe, ask for the real thing
 AC_CHECK_FUNCS([openat renameat mkdirat fstatat unlinkat])
 
-AC_CHECK_HEADERS_ONCE([sys/eventfd.h])
-AC_CHECK_FUNCS([epoll_wait eventfd])
+AC_CHECK_FUNCS([epoll_wait epoll_pwait ppoll])
 
 dnl libkqueue should work in the future
 AC_CHECK_FUNCS([kqueue])