about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a18ea15..69b347e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -193,6 +193,7 @@ $(top_srcdir)/NEWS: configure.ac
 $(top_srcdir)/ChangeLog: configure.ac
         $(AM_V_GEN)$(RAKE) -sq changelog > $@.$$$$ && mv $@.$$$$ $@
 
+GZIP = gzip
 RSYNC = rsync
 RSYNC_DEST = bogomips.org:/srv/bogomips/cmogstored/
 WWW_DOC = README AUTHORS NEWS.atom.xml INSTALL $(extra_doc)
@@ -203,8 +204,9 @@ publish: NEWS.atom.xml NEWS ChangeLog
 # n.b. git set-file-times is non-standard, but distributed with rsync
         -cd $(top_srcdir) && git set-file-times $(WWW_DOC)
         $(INSTALL_DATA) -p $(addprefix $(top_srcdir)/,$(WWW_DOC)) www/
-        cd www && for i in $(WWW_DOC); do \
+        set -e && cd www && for i in $(WWW_DOC); do \
                 $(GZIP) < $$i > $$i.gz; \
+                test -s $$i.gz; \
                 touch -r $$i $$i.gz; \
         done
         $(RSYNC) -av www/ $(RSYNC_DEST)