about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 0272608..2ad5d73 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -187,26 +187,29 @@ cmogstored.1: cmogstored.x cmogstored.c
         $(HELP2MAN) -i $< -N $(top_builddir)/cmogstored > $@.$$$$ && \
         mv $@.$$$$ $@; fi
 
+vcs_doc := README INSTALL TODO doc/queues.txt doc/design.txt
 extra_doc = HACKING NEWS ChangeLog TODO
 RAKE = rake
 $(top_srcdir)/NEWS: configure.ac
         $(AM_V_GEN)$(RAKE) -sq news > $@.$$$$ && mv $@.$$$$ $@
 $(top_srcdir)/ChangeLog: configure.ac
         $(AM_V_GEN)$(RAKE) -sq changelog > $@.$$$$ && mv $@.$$$$ $@
+$(top_srcdir)/cmogstored.1.txt: $(top_srcdir)/cmogstored.1
+        $(AM_V_GEN)man --nh $(top_srcdir)/$< > $@.$$$$ && mv $@.$$$$ $@
 
 GZIP = gzip
 RSYNC = rsync
 RSYNC_DEST = bogomips.org:/srv/bogomips/cmogstored/
-HTML_DOC = README INSTALL $(extra_doc) doc/queues.txt doc/design.txt
+HTML_DOC = $(vcs_doc) HACKING NEWS ChangeLog cmogstored.1.txt
 WWW_DOC = $(HTML_DOC) NEWS.atom.xml
 NEWS.atom.xml: configure.ac
         $(AM_V_GEN)$(RAKE) -sq news_atom > $@.$$$$ && mv $@.$$$$ $@
 
 html = $${i%.txt}.html
-publish: NEWS.atom.xml NEWS ChangeLog
+publish: NEWS.atom.xml NEWS ChangeLog cmogstored.1.txt
         mkdir -p www/examples/
 # n.b. git set-file-times is non-standard, but distributed with rsync
-        -cd $(top_srcdir) && git set-file-times $(WWW_DOC)
+        -cd $(top_srcdir) && git set-file-times $(vcs_doc)
         $(INSTALL_DATA) -p $(addprefix $(top_srcdir)/,$(WWW_DOC)) www/
         $(INSTALL_DATA) -p $(addprefix $(top_srcdir)/,$(examples)) \
                 www/examples/