about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8554281..8a9c952 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -96,9 +96,9 @@ mog_src += yield.c
 
 LDADD = $(LIBINTL) $(top_builddir)/lib/libgnu.a libnostd.a $(LIB_CLOCK_GETTIME)
 noinst_LIBRARIES = libnostd.a
-NOSTD_CFLAGS = -include $(top_builddir)/$(CONFIG_HEADER)
+nostd_include = -include $(top_builddir)/$(CONFIG_HEADER)
 libnostd_a_SOURCES = nostd/setproctitle.c nostd/setproctitle_noop.c
-libnostd_a_CFLAGS = $(AM_CFLAGS) $(NOSTD_CFLAGS)
+libnostd_a_CFLAGS = $(AM_CFLAGS) $(nostd_include) $(NOSTD_CFLAGS)
 
 RLFLAGS = -G2 -e
 RAGEL = ragel