about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2013-01-30 02:55:29 +0000
committerEric Wong <normalperson@yhbt.net>2013-01-31 03:33:04 +0000
commit088138b235e79fa54a4e3602a4d60975e9581571 (patch)
tree56e37cf2603bbe552cd84248aeecaefd94fb625d /Makefile.am
parent2b252bb6b4704be01d629194aff588b24d579cdd (diff)
downloadcmogstored-088138b235e79fa54a4e3602a4d60975e9581571.tar.gz
USR2 now forks a new cmogstored process which inherits
listener file descriptors from the parent.  The parent
renames its pidfile with a ".oldbin" suffix so the new
child can use the new PID file.

Clusters may now upgrade to future versions of cmogstored
without needing to mark hosts down via mogadm.

The behavior of this process should match that of nginx:
http://wiki.nginx.org/CommandLine#Upgrading_To_a_New_Binary_On_The_Fly
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 39011aa..09e712f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -83,6 +83,7 @@ mog_src += svc_dev.c
 mog_src += thrpool.c
 mog_src += trywrite.c
 mog_src += util.h
+mog_src += upgrade.c
 mog_src += warn.c
 
 LDADD = $(LIBINTL) $(top_builddir)/lib/libgnu.a libnostd.a